Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
in Q2A Core by
When I start a new question on this site, after typing the title, I see related topics right under the title input line.

On my site Q2A 1.7, I don't see such related topics - I have tried multiple keywords just to be sure.

** the same way, I don't see matching tags.

Please help.

2 Answers

+1 vote

Hello @steven2, for similar questions check you need to enable an option in admin > posting > "Check for similar questions when asking:"

For matching tags to show, you need to enable an option in admin > posting > Show example tags based on question.    You can also enable "Show matching tags while typing" (just in case you need it).

I hope this helps.

Thank you very much, Gurjyot Singh.  Your recommendation worked perfect. Somehow it is not working on my Windows/localhost machine, but works perfect on my linux server. Good enough for me.
It should work on localhost as well... May be you are not having much questions or tags to show up for matching question.
And I am glad that my answer helped you... :)
Neither tags or related questions work on my localhost.  I have plenty of posts/tags there (actually it is almost exact copy of my remote db).  Ajax call is triggering, but seems nothing is coming back.  Some kind of bug I presume.  I have no time to fix, but good enough.
+2 votes

You mentioned your local database was almost a copy of your production database. Smells like you've done some manual data migration of the main tables and expected that to work. If that is the case, it is a data issue which has nothing to do with the code. In fact, if that is the case, you shouldn't be able to search for those imported posts either (you could search for localhost-created ones, though)

You might have a chance if you navigate to admin/stats and execute the cleanup operations and try again (assuming you have the "Check for similar questions when asking" options enabled).

@pupi1985 (+1) you were right.  I reindexed from admin, and related questions are now working.  I thought I had done that, but apparently something went wrong. Thanks for the tip.  It is "usually" a data issue as you pointed out.