Unfortunately not. Those PHP versions still have a lot of usage - PHP 5.5 and below accounts for over 65% of all PHP websites according to w3techs. We can't shut out that many people.
PHP 5.2 is now below 10% so it will be ditched in the next version. However, when development on v1.8 started it was higher so I decided on that as the supported version and cannot change mid way through.
The security issue is not as big a deal as it seems. Firstly, many server operating systems (like Ubuntu or CentOS) back-port fixes from later versions - so if your version says PHP 5.3 you will likely have security fixes from 5.4, 5.5 etc. Secondly, it's almost unheard of that a security issue in an old PHP version suddenly makes all sites on that version vulnerable. It usually depends on very specific and rare circumstances.
Speed is of course a great reason to upgrade but it's up to the users of Q2A to do that. We strongly encourage everyone to be on at least 5.6 if not 7.x.
Welcome to the Q&A site for Question2Answer.
If you have a question about Q2A, please ask here, in English.
To report a bug, please create a new issue on Github or ask a question here with the bug tag.
If you just want to try Q2A, please use the demo site.