Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+26 votes
294 views
in Q2A Core by

Hi,

About a month ago, I upgraded my website to (PHP- 8.1). And There were problems such as uploading and displaying avatars, local mail, and a lot of error messages (PHP Deprecated), However, after I used (bugfix-pupi1985), either by changing some codes or overwrite some files, all the error messages disappeared and the site now works fine.

 : But one problem remained which is

PHP Deprecated: mb_strtolower(): Passing null to parameter #1 ($string) of type string is deprecated in /home1/xxxxxx/public_html/xxxxxx/qa-include/util/string.php on line 765)

 This error appears in the error log after adding an answer, comment, or modification.

I will be very grateful and appreciative for your cooperation

Q2A version: 1.8.6

1 Answer

+2 votes
by
selected by
 
Best answer

You can install Q2A 1.8.7 which fixes these issues. Download from here

by
Thank you so much Scott, it's good news for me and for other users ..✨
...