Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
283 views
in Q2A Core by
edited by

I have installed Question2Answer under a subdomain, with my WP site under the main domain. I followed the WP install procedure up to and inc step 6. But when I tried step7 (Open the appropriate web page for Question2Answer in your web browser), I get:

Forbidden You don't have permission to access this resource. 

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

My first thought was that it was because I hadn't yet gone live with the site.. So I went live to test it, but got the same error. Can anyone advise?

Q2A version: 1.8.6

1 Answer

0 votes
by
A 403 Forbidden error typically indicates that the web server is denying access to the requested resource. There are several possible causes for this error, including incorrect file permissions, a misconfigured .htaccess file, or a server-side security setting.

To troubleshoot the issue, you can try the following steps:

1- Check the file permissions on the Question2Answer directory and its contents to ensure that they are set correctly.

2- Verify that the .htaccess file in the Question2Answer directory (if it exists) does not contain any rules that might be blocking access to the site.

3- Check the server logs to see if there are any error messages or other clues as to what might be causing the issue.

4- Contact your web hosting provider or server administrator for further assistance, as they may be able to provide additional insight into the problem.

It's also worth noting that some web hosts may have specific requirements or limitations for running Question2Answer or other web applications, so it's possible that the issue could be related to your hosting environment.
...